Buy Yamaha Outboard Parts


No announcement yet.

Command Link Tach and Hour Meter Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Command Link Tach and Hour Meter Problem

    Hi All,

    I have twin 4 stroke F115 Yamahas on my 2008 RF246.

    The Command Link is the Square Tach version 6Y8-8350T-0
    Speed and Fuel Meter is 6Y8-83500-0

    For some reason BOTH Tach units are now not functioning correctly. Upon power up all 3 units display the Welcome screen but do not get to the 0 rpm screen and hour meter display. There only is a dark line. See attached pic.

    Only 2 explanations; I recently had shift control cables replaced so there was some increased activity in the forward electronics cuddy. But the tachs were working fine after I got the boat back.

    I also worked on my horn and caused a spark on the main power breaker panel ground Bus. It seems though that there are no connections or fuses to the Command Link system that I can see in the forward electronics cuddy and my motor tech does not think it likely this was the cause. Although, The tachs were not working some time after I caused this spark.

    I am wondering if anyone has had a similar problem and can offer any advice.

    Might there be a fuse that has escaped me?

    Is there a reset that can be done? Not in the manual. Re-number the engines?

    I have looked for loose wires

    The engines are charging fine.

    My reading on this and other forums has suggested the Engine control module. I plan to locate that and see if all the connections look good. Not sure if this can be troubleshot.

    Wonder if there is any good way to isolate the problem? Having both tachs go, it seems unlikely it's anything on the engine side.

    As you can see I ' m grasping for straws and of course have a 3 week trip coming up soon.

    Hope someone can help.
    Many Thanks in advance


  • #2
    There is only one power supply involved, coming off the ignition key
    goes to the 'hub' that the gauges plug into.

    So since you're getting the 'welcome screen' - power is fine.
    (that's the red wire, and the black ground wire, in the 4-wire harness to the gauge)

    "Data" moves on the white and the blue wires.

    At each engine, there is a cable from the engine harness,
    going to a 'hub' inside the boat (likely near the transom)

    and then there is another harness,
    connecting that rear hub to another at the helm.

    I suppose you could have a 'bad connection' between aft and forward hubs -
    that would affect both tachs.

    Other than a 'mechanical' issue with the wiring,

    the only other thing I can suggest, as you mention:
    the procedure described in the Operation Manual for "Resetting Engine Numbers"
    and then re-initialize.

    One almost never hears of an actual problem with Yamaha engine ECMs,
    and I have never heard of an ECM 'losing' Command Link output
    while still otherwise functioning perfectly.
    (and really implausible for two engine ECMs simultaneously.

    Do you have a GPS/chartplotter /multifunction display that has NMEA 2000 capability?
    Connecting that could show if the ECMs outputting the data.


    • #3
      Thx Fairdeal

      Just got back from the boat and found the rear hub on the transom. Undid the connector of the 4 wires running forward and at the connector of the forward hub. Shorted white and blue at one end and got good continuity at other end. Same with red and black so I think the boat-long harness is ok.

      Also checked one fuse and undid every connector I could find and reset. Again there is power to each of the 3 gauges. Still same problem though.

      I have been avoiding any reset as I would hope not to loose my engine hours but after 3 days of fiddling that time has come.... as I'm putting no hours on it now to worry about.

      I do have a new Garmin that may have NMEA 2000. I'm not sure where that would be wired to. Would this display speed only to the speed/fuel centre gauge? I think that gauge is working ok but I need to check this weekend.

      I am not actually sure if the Raymarine is hooked up to the unit to show speed or if it is the other method.

      I will try the reset next or any other suggestions anyone has.

      Thanks so much for the great help.



      • #4
        Hi Glen -

        don't worry about losing engine hours when you reset the gauges -
        it won't happen.

        unlike the older style Yamaha tach - which actually counted the hours -
        the Command Link gauge just displays what it receives from the ECM

        the hours are 'permanently written into" the engine ECM,
        and 'broadcast' to the gauge


        • #5
          Update: Reset the engine Numbers and no changes.

          Also found the fuses in the motors and checked the ones for the ECU. Pulled them out hoping for a reset and fuses good. No change

          Both motors, ECU's, connectors etc. look good and tight.

          Here's a little more detail.

          Speed Fuel Gauge
          Speed and water depth is coming in from Raymarine and being displayed.
          Gas gauge has bars that seem right.

          Both Tachs
          Rpm is a single solid bar that does not flash, no hour display
          No temp, voltage Battery, Oil pressure
          Tilt: one bar only is flashing; when you tilt up motor no change

          Some more questions
          Do either of those hubs have fuses in them? I suspect they are just wiring harnesses . They are both hard to open on my boat.

          Is there any way to check if the ECU is sending out any data?

          Is there any way to reset the ECU?

          I am getting close to pulling the boat for a mechanic to look at as I am running out of ideas.

          Thanks in advance for any further ideas.



          • #6
            The hubs are just wiring connectors.
            'Power' and "ground' are inserted at the front hub -
            since the Tachs are "on" - they are getting power.

            Everything that the tachs need to 'display" -
            rpm, temp, pressure, trim -
            comes in on those white & blue wires.

            A way to "check whether the data is there"
            is to connect a NMEA 2000 capable chartplotter
            but you need to adapt it's standard NMEA plug to the Yamaha hub.

            What model Raymarine? and you said you have a new Garmin?

            There is no 'reset' for the engine ECM -
            and I mentioned earlier -
            I have never heard of an ECM 'failing' to provide Command Link data.
            And BOTH of your engines?

            I keep thinking it must be a wiring problem.
            Are the gray terminator caps in place on both hubs?


            • #7

              Thanks Fairdeal

              That pic is from is my exact setup. Nice

              I have a pic of the Helm hub see below but I didn't take one from the aft. I'll go back to the boat and chk. I just thought these were dummy plugs but they may be shorting plugs?

              The only part I can't access is under the ignition. I am assuming this would control power only and as I have power there on all 3 gauges shouldn't be any reason to chk further.???

              I am going to chk for continuity again front to aft. as far as I can go.

              The attached pics are from this morning under power. Speed is coming in from the Raymarine C120. Seems to be reading and displaying Fuel bars as well. Both tachs are the same; powered, but displaying no information.

              Sorry I have a Humminbird Helix 10 unit 2 years old. I'm not sure what I would be connecting it to for testing purposes. Can you elaborate?

              When running can I take a tach plug off and test for voltage coming on the white and blue wires? I assume this would be a DC test and I would go; white+ and Black- and then Blue+ and Black-

              Thanks again for your help.



              • #8
                I see what you are suggesting to run the tach into the Helix as a test. Looks like my Helix 10 needs an adaptor to make this work. So that's a no go.

                If a mm doesn't work for the above test, I wonder if a scope could be used? Just to see something coming out of the ECU would seem to point at the tachs.

                Seems very strange that 2 tachs could go at the same time. Not impossible my mechanic who was working at the transom knocked out the gray plug. That would be too easy.....but would explain things much better than alot of the other ideas I've been coming up with.



                • #9
                  Hi Fairdeal

                  I checked continuity and the rear hub yestarday.

                  The rear hub had all the plugs in it but it is hooked up in a different configuration from that on your diagram. See my pic attached. I'm not sure this makes any difference as my continuity testing revealed the following.

                  I went to both engines and found the red and black wire and connector. See pic. I ran a wire sequentially from each female lead on the engine connectors to the female leads on the back of both tachs.

                  Each wire had continutity on both engines tachs . So a test on the blue wire on the Port engine would ring out on the Blue port and Starboard Tach wire. Same with each of the red, Black and White wires.

                  That suggests to me the wiring is all in parallel (both Port and Star engine data running up on same lines) which I wouldn't of thought of at first.

                  So if each engine must put out it's own coded digital message saying I am engine 1 and here is your data, then does the Port tach parse that part of string out and display it? Same for Star Tach.

                  I did try to fiddle with the connectors at the transom hub as the port engine is coming on the side closest to the starboard and then to your configuration. No luck. But if they are all wired in parallel I think this makes sense.

                  This could be where the problem is though if I have these mixed up and then have to re-number engines again.

                  I attach a couple of pics.. The rear hub is looking to stern so the red connector is to starboard. The port engine is the white one closest to Starboard side (odd).

                  Many thanks for any continued suggestions. 20190803_182856.jpg20190803_170003.jpg


                  • #10
                    Command Link is Yamaha's name for NMEA 2000,
                    done using their proprietary wiring connectors.

                    The 'physical architecture' is identical to NMEA 2000,
                    which copies a broader standard called "DeviceNet",
                    and is structured as a 'backbone' with each device as a 'node'

                    the data is 'carried' via the blue wire and the white wire -
                    which run parallel to each other along the backbone
                    and then - at each extreme end -
                    are joined to each other with 120 ohm resistors.

                    That means you will have:
                    - 'zero' ohm continuity between a white wire at any point, and a white wire at any other point

                    - likewise, 'zero' ohm continuity between a blue wire at any point, and a blue wire at any point

                    - and 60 ohms resistance between a white wire and a blue wire.

                    The red power wire, and the black ground,
                    there to power to run any devices that need it -
                    like the Yamaha gauges
                    (you'll note the Yamaha engine ECM does NOT use any power,
                    or the ground, from the backbone).

                    However I've read that the ground is also used as a 'reference'
                    by devices to measure the signals in the white and blue wires.
                    Last edited by fairdeal; 08-04-2019, 12:40 PM.


                    • #11
                      Fairdeal, did you know or have you thought about the fact that having one 60 ohm resistor between the white wire and the blue wire will result in one CL tachometer working just fine?


                      • #12
                        Originally posted by boscoe99 View Post
                        Fairdeal, did you know or have you thought about the fact that having one 60 ohm resistor between the white wire and the blue wire will result in one CL tachometer working just fine?
                        this is a fact? was not aware
                        nor would I ever imagine such a thing

                        while I "know" how the wiring is supposed to be arranged,
                        an understanding of what is happening 'underneath' is absolutely beyond me...


                        • #13
                          Made some headway yestarday. When we disconnected the starboard tach, with both engines running, the port tach immediately started working. We then turned off the port engine and ran the starb engine onto the port tach by renumbering it to engine 2. Port tach worked again. So that seems to prove all the wiring harnesses are working and both ECU's are putting out data. Yah!

                          That just leaves the starb tach which may be shorted out. We took apart the Helm hub and all those connectors seem to join up on 4 separate brass seem to be wired in parallel. A short in one tach would would then likely take out/load down the other?

                          We also checked both resistors and got 119ohms so they look good.

                          Is there a way to chk the tachs? Would I expect 60ohms between the white and blue pins equivalents on the back of the tach? Or a chk on other pins to see if it is shorted.

                          Interesting stuff......Boscoe, I'm not sure I understand your comment about the 60ohms, but this new info may be relevant.

                          Thanks Guys, Getting there. Looking at new tachs, unless I can find a way to open the tach up. looks completely sealed.



                          • #14
                            Did you ever sort this out? I believe I'm having the same problem. I see this is a couple years old, any chance of the op still being around?


                            • #15
                              I'm Having the exact same problem and ran through the same steps as Grayharp but no luck.