Yamaha Outboard Parts
Yamaha   Yamaha Outboard Parts
 
Yamaha Outboard Forum Yamaha Outboard Parts Discussion Forum Yamaha Outboard Parts Boat Parts Yamaha Outboard Forum Outboard Motor Parts Contact Us
Yamaha Parts
  #1 (permalink)  
Old 09-04-2004
<David>
Guest
 
Posts: n/a
Post

Today I ended up in some shallow water in my skiff and when I got out, the amount of water being pumped through the motor was restricted. I still have some water flow, but I'd say it is about 25% of normal. It did not get too hot, so I don't feel I did any damage to the motor, however, I don't see any obvious issues outside the motor, so I suspect something has partially obstricted the cooling water inside or at the impeller.

Where should I start looking? Any common areas where these motor may get clogged up?

This a 2 year old, 25HP 2 stroke.

Many thanks,

David
Reply With Quote
  #2 (permalink)  
Old 09-13-2004
<boats.net>
Guest
 
Posts: n/a
Post

If it is not overheating then it is probably a pluged hose at the Pee hole , Flush out with fresh water and clean hose, The water pump impeller probably was damaged to some degree and needs to be checked out
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 06:50 AM.

Outboard Parts

Other Forums
Mercury Parts
Suzuki Parts
Evinrude Parts
Johnson Parts
Honda Parts

Copyright 2000 - 2014, Outdoor Network LLC